`
hellojyj
  • 浏览: 58936 次
  • 性别: Icon_minigender_1
  • 来自: 长沙
社区版块
存档分类
最新评论

HDU1022--火车进出站问题Ⅰ

    博客分类:
  • ACM
阅读更多

原题:http://acm.hdu.edu.cn/showproblem.php?pid=1022

 

Train Problem I

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 18882    Accepted Submission(s): 7099


Problem Description

 

As the new term comes, the Ignatius Train Station is very busy nowadays. A lot of student want to get back to school by train(because the trains in the Ignatius Train Station is the fastest all over the world ^v^). But here comes a problem, there is only one railway where all the trains stop. So all the trains come in from one side and get out from the other side. For this problem, if train A gets into the railway first, and then train B gets into the railway before train A leaves, train A can't leave until train B leaves. The pictures below figure out the problem. Now the problem for you is, there are at most 9 trains in the station, all the trains has an ID(numbered from 1 to n), the trains get into the railway in an order O1, your task is to determine whether the trains can get out in an order O2.
 

 

Input

 

The input contains several test cases. Each test case consists of an integer, the number of trains, and two strings, the order of the trains come in:O1, and the order of the trains leave:O2. The input is terminated by the end of file. More details in the Sample Input.
 

 

Output

 

The output contains a string "No." if you can't exchange O2 to O1, or you should output a line contains "Yes.", and then output your way in exchanging the order(you should output "in" for a train getting into the railway, and "out" for a train getting out of the railway). Print a line contains "FINISH" after each test case. More details in the Sample Output.
 

 

Sample Input
3 123 321 3 123 312
 

 

Sample Output
Yes. in in in out out out FINISH No. FINISH
Hint
Hint
For the first Sample Input, we let train 1 get in, then train 2 and train 3. So now train 3 is at the top of the railway, so train 3 can leave first, then train 2 and train 1. In the second Sample input, we should let train 3 leave first, so we have to let train 1 get in, then train 2 and train 3. Now we can let train 3 leave. But after that we can't let train 1 leave before train 2, because train 2 is at the top of the railway at the moment. So we output "No.".
 



其实关于这道题呢,难度还比上解析四则运算。我这里给大家分享下解题过程。火车进出站问题一般都要涉及到栈结构。本质就是进入过程能否和出去过程匹配的问题。分别把进入过程和出去过程放在两个数组。然后对进入过程设置指针p1,出去过程设置指针p2,如果p1==0,那么p1指向的车厢进入栈,如果p!=0;询问下栈顶元素和p2指向的车厢是否相等,相等就用while() pop();p2++;一直到栈为空或者stack.top()!=p2指向的车厢;一直到p1指到超过了最末尾车厢;“in”和“out可以在每次对栈结构操作时(pop()=>out,push()=>in),存放在一个string类型的数组里卖,最后如果栈是空的表示能够按照给你的出战顺序实现,那么输出Yes.步骤呢只要按照格式输出数组中的所有元素就可以了。如果栈不是空的,那就不行就输出No.

 

代码如下:

#include<iostream>
#include<stack>
#include<string>
using namespace std;
int main(){
    int count;
    while(cin>>count){
        char num1[9],num2[9];
        string op[100];
        stack<char> st;
        int j=0;
        int p=0;
        int cp=0;
        for(int i=0;i<count;i++){
            cin>>num1[i];
        }
        for(int i=0;i<count;i++){
            cin>>num2[i];
        }
        while(p<=count){
            if(!st.empty()){
                if(st.top()==num2[j]){
                    while(!st.empty()&&st.top()==num2[j]){
                        st.pop();
                        op[cp++]="out";
                        j++;
                    }
                    if(p==count){
                        break;
                    }

                }else{
                    st.push(num1[p++]);
                    op[cp++]="in";
                }
            }else{
                st.push(num1[p++]);
                op[cp++]="in";
            }
        }
        if(!st.empty()){
            cout<<"No."<<endl;
            cout<<"FINISH"<<endl;
        }else{
            cout<<"Yes."<<endl;
            for(int a=0;a<cp;a++){
                cout<<op[a]<<endl;
            }
            cout<<"FINISH"<<endl;
        }

    }
    return 0;
}

 

0
0
分享到:
评论

相关推荐

Global site tag (gtag.js) - Google Analytics